problemas acestream

Programas compilados para Manjaro. Problemas, sugerencias.
Reglas del Foro
Lea las normas y conductas de la comunidad en "Zona Normatividad".
Busca antes de preguntar en Google y en el buscador de este foro.
Si se soluciona tu problema presione el botón en V de color verde, Imagen, para añadir un [Solucionado].

problemas acestream

Notapor rokeroteam » Sab, 13 May 2017, 18:51  •  [Mensaje 1]

hola, saludos a todos, he logrado instalar acestream-engine, el acestream-player y player data, aunque me ha costado resolver ciertos errores que me daban los paquetes leyendo los mensajes de aur puestos por los usuarios los he logrado resolver todos, pero luego de instalarlo todo no logro arrancar en engine de ninguna manera, pongo información de los errores por si alguien puede hecharme una mana, gracias de antemano, estoy usando archlinux con kde.

estos son los errores en la terminal.

acestreamengine --client-console
2017-05-13 17:38:07,663|MainThread|acestream|init segmenter done: log_path=/home/usuario/.ACEStream/logs/segmenter.log
2017-05-13 17:38:07,664|MainThread|acestream|platform=linux
2017-05-13 17:38:07,664|MainThread|acestream|app=acestream
2017-05-13 17:38:07,664|MainThread|acestream|version=3.1.16 code=3011600 revision=3258 date=2017-02-08
2017-05-13 17:38:07,664|MainThread|acestream|use_local_db=True
2017-05-13 17:38:07,665|MainThread|acestream|use_m2crypto=True
2017-05-13 17:38:07,665|MainThread|acestream|enable debug: 0
2017-05-13 17:38:07,666|MainThread|acestream|get_default_api_version: 2
2017-05-13 17:38:07,666|MainThread|acestream.coreapp|use fixed i2i_port: 62062
2017-05-13 17:38:07,666|MainThread|acestream.coreapp|state_dir=u'/home/usuario/.ACEStream'
2017-05-13 17:38:07,719|MainThread|acestream.coreapp|cannot load session config, use default
sh: /bin/netstat: No existe el fichero o el directorio
sh: /sbin/ifconfig: No existe el fichero o el directorio
2017-05-13 17:38:07,810|MainThread|acestream.SocketHandler.InterruptSocket|bound on 127.0.0.1:39116
2017-05-13 17:38:07,811|MainThread|acestream.SocketHandler.SocketHandler|failed to bind: addrinfo=[2, None, None, None, ('', 8621)]
2017-05-13 17:38:07,812|MainThread|acestream|failed to init app
Traceback (most recent call last):
File "core.c", line 336, in
File "core.c", line 1064, in
File "core.c", line 1054, in
File "ACEStream/Core/Session.py", line 293, in __init__
File "ACEStream/Core/APIImplementation/LaunchManyCore.py", line 125, in register
File "ACEStream/Core/BitTornado/RawServer.py", line 141, in find_and_bind
File "ACEStream/Core/BitTornado/SocketHandler.py", line 450, in find_and_bind
File "ACEStream/Core/BitTornado/SocketHandler.py", line 420, in bind
error: [Errno 98] Address already in use


acestreamengine --client-gtk --gui-gtk
load config from file: /opt/acestream/acestream.conf
Failed to init log file: [Errno 13] Permission denied: '/opt/acestream/acestream.log'


Sudo acestreamengine --client-gtk --gui-gtk
[sudo] password for usuario:
load config from file: /opt/acestream/acestream.conf
sh: /bin/netstat: No existe el fichero o el directorio
sh: /sbin/ifconfig: No existe el fichero o el directorio


sudo acestreamengine --client-gtk --gui-gtk
load config from file: /opt/acestream/acestream.conf
sh: /bin/netstat: No existe el fichero o el directorio
sh: /sbin/ifconfig: No existe el fichero o el directorio


Me he encontrado cierta información que me hacia pensar que el problema lo daba una biblioteca que se actualizo y no dejaba con la actualización, funcionar bien el programa, esta fue la solución que aplique

mensaje 1

Acestream-launcher does not work with the new version openssl
Acestream engine running. xx Cannot load libraries: path /opt/acestream/lib Traceback (most recent call last): File "<entry>", line 9, in <module> File "core.c", line 132, in ImportError: /usr/lib/libcrypto.so.1.0.0: versionOPENSSL_1.0.0' not found (required by /opt/acestream/lib/acestreamengine/pycompat.so)
Error authenticating to Acestream!
Media Player not running...`
openssl-1.0-1.0.2.k-3
With version openssl-1.0-1.0.2.k-2 there are no problems

mensaje 2

temporary workaround:
install libopenssl-1.0-compat and
sudo ln -sf /usr/lib/libcrypto-compat.so.1.0.0 /opt/acestream/lib/libcrypto.so.1.0.0
solves the problem, but... (((
It's a crutch

sacadado de la siguiente direccion lugar de donde saque la "solución"

lo dicho gracias a todos por mantener estos foros y podamos documentarnos para aprender.
rokeroteam

Novato
 
Mensajes: 2
Registrado: Sab, 13 May 2017, 17:48
Distro actual: arch linux
Versión: rolling release
Escritorio: kde
Rama: estable

  • Temas Parecidos
    Respuestas
    Vistas
    Último mensaje

Volver a Software



¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 2 invitados




StaffBorrar las cookies


^ Ir Arriba