Problema Wine/playonlinux y pulseaudio 5.0  [Solucionado]

Para los más jugones, en este foro se tratarán los temas tanto de juegos nativos como los que requieran emulación.
Reglas del Foro
Lea las normas y conductas de la comunidad en "Zona Normatividad".
Busca antes de preguntar en Google y en el buscador de este foro.
Si se soluciona tu problema presione el botón en V de color verde, Imagen, para añadir un [Solucionado].

Problema Wine/playonlinux y pulseaudio 5.0

Notapor Cristian Moreno » Mié, 26 Mar 2014, 16:10  •  [Mensaje 1]

hola, desde la ultima actualización de pulseaudio con el paquete de actualización de manjaro presento un problema al iniciar juegos con wine. tenia la versión pulseaudio libpulse y lib32-libpulse 4.0-6. pero ahora al intentar abrir los dos juegos de wine que tengo (starcraft 1, LOL) me sale este error

ALSA lib dlmisc.c:252:(snd1_dlobj_cache_get) Cannot open shared library /usr/lib32/alsa-lib/libasound_module_pcm_pulse.so

Buscando por internet lei que era un problema de compatibilidad de pulseaudio 5.0 y wine y que se soluciona con un downgrade al 4.0-6 mientras se soluciona. Instale el paquete downgrade de AUR, pero al intentar hacer el downgrade a pulseaudio me sale:

[rodrigo@rodrigo-linux ~]$ sudo downgrade pulseaudio
[sudo] password for rodrigo:
Available packages:

1) pulseaudio-5.0-1-x86_64.pkg.tar.xz (remote)
2) pulseaudio-4.0-6-x86_64.pkg.tar.xz (remote)
3) pulseaudio-4.0-5-x86_64.pkg.tar.xz (remote)
4) pulseaudio-4.0-2-x86_64.pkg.tar.xz (remote)

select a package by number: 2

cargando paquetes...
atención: desactualizando la versión del paquete pulseaudio (5.0-1 => 4.0-6)
resolviendo dependencias...
atención: no se pudo resolver "libpulse=4.0-6", una dependencia de "pulseaudio"
:: El siguiente paquete no se puede actualizar debido a dependencias que no se pudieron resolver:
pulseaudio

:: ¿Quiere omitir el siguiente paquete para esta actualización? [s/N] n
error: error al preparar la transacción (no se pudieron satisfacer las dependencias)
:: pulseaudio: necesita libpulse=4.0-6



lo mismo con libpulse:

[rodrigo@rodrigo-linux ~]$ sudo downgrade libpulse
Available packages:

1) libpulse-5.0-1-x86_64.pkg.tar.xz (remote)
2) libpulse-4.0-6-x86_64.pkg.tar.xz (remote)
3) libpulse-4.0-5-x86_64.pkg.tar.xz (remote)
4) libpulse-4.0-2-x86_64.pkg.tar.xz (remote)

select a package by number: 2

cargando paquetes...
atención: desactualizando la versión del paquete libpulse (5.0-1 => 4.0-6)
resolviendo dependencias...
verificando conflictos...
error: error al preparar la transacción (no se pudieron satisfacer las dependencias)
:: pulseaudio: necesita libpulse=5.0-1
[rodrigo@rodrigo-linux ~]$


Como hago downgrade a estos paquetes?. Gracias

claro que siempre que actualizo realizo sudo pacman -Scc
Avatar de Usuario
Cristian Moreno

Miembro
 
Mensajes: 157
Registrado: Jue, 19 Sep 2013, 01:47
Ubicación: Bogotá
Distro actual: Manjaro
Versión: 0.8.7.0
Escritorio: xfce

Re: Problema Wine/playonlinux y pulseaudio 5.0

Notapor K|Ke » Mié, 26 Mar 2014, 16:27  •  [Mensaje 2]

Cristian Moreno escribió:Como hago downgrade a estos paquetes?. Gracias

claro que siempre que actualizo realizo sudo pacman -Scc


No es recomendable realizar periódicamente un borrado de la caché de Pacman, ya que en el guardas paquetes indispensables para realizar un downgrade ante una necesidad como la que estás teniendo en este momento, sin los paquetes de dependencias necesarias en tu sistema, no podrás realizar lo que necesitas.

Saludos.
K|Ke
Manjaro Linux Comunidad Hispana
Administrador de Sistema

"Las personas nacen libres e iguales en dignidad y derechos"
Personal LiCo
Avatar de Usuario
K|Ke

Administrador
 
Mensajes: 1069
Registrado: Dom, 18 Ago 2013, 17:06
Ubicación: Región de Atacama - Chile
Distro actual: Arch y Manjaro Linux
Versión: Comunitaria
Escritorio: Fluxbox
Rama: Unstable

Re: Problema Wine/playonlinux y pulseaudio 5.0

Notapor Cristian Moreno » Mié, 26 Mar 2014, 18:08  •  [Mensaje 3]

entonces no hay manera. ¿Puedo desinstalar e instalar una versión anterior?
Avatar de Usuario
Cristian Moreno

Miembro
 
Mensajes: 157
Registrado: Jue, 19 Sep 2013, 01:47
Ubicación: Bogotá
Distro actual: Manjaro
Versión: 0.8.7.0
Escritorio: xfce

Re: Problema Wine/playonlinux y pulseaudio 5.0

Notapor cuentos » Mié, 26 Mar 2014, 18:56  •  [Mensaje 4]

Prueba a bajarlo desde aquí:
https://www.dropbox.com/s/fk9y57oj0zqq6 ... pkg.tar.xz
https://www.dropbox.com/s/ueak9g86tmp6d ... pkg.tar.xz
Son los archivos de mi sistema, los descargas y pegas en
Código: Seleccionar todo
/var/cache/pacman/pkg/
Twitter @mcuentos
Avatar de Usuario
cuentos

Moderador
 
Mensajes: 443
Registrado: Mié, 28 Ago 2013, 06:12

Re: Problema Wine/playonlinux y pulseaudio 5.0  [Solucionado]

Notapor Cristian Moreno » Mié, 26 Mar 2014, 19:49  •  [Mensaje 5]

oye, funciono, muchas gracias :)
Avatar de Usuario
Cristian Moreno

Miembro
 
Mensajes: 157
Registrado: Jue, 19 Sep 2013, 01:47
Ubicación: Bogotá
Distro actual: Manjaro
Versión: 0.8.7.0
Escritorio: xfce

Re: Problema Wine/playonlinux y pulseaudio 5.0

Notapor cuentos » Mié, 26 Mar 2014, 20:17  •  [Mensaje 6]

Cristian Moreno escribió:oye, funciono, muchas gracias :)

Ok, pero explica bien como. Descargaste los archivos y te funciono hacer el downgrade
Twitter @mcuentos
Avatar de Usuario
cuentos

Moderador
 
Mensajes: 443
Registrado: Mié, 28 Ago 2013, 06:12

Re: Problema Wine/playonlinux y pulseaudio 5.0

Notapor Cristian Moreno » Mié, 02 Abr 2014, 14:12  •  [Mensaje 7]

bueno, con el paquete downgrade que instale desde AUR, hice en la terminal

sudo downgrade pulseaudio libpulse lib32-libpulse

se descargan los paquetes en mi home, y esos paquetes los pego en

/var/cache/pacman/pkg/

ahora,hago un sudo pacman -U (arrastro cada paquete desde /var/cache/pacman/pkg/

sudo pacman -U /var/cache/pacman/pkg/pulseaudio-4.0-6-x86_64.pkg.tar.xz /var/cache/pacman/pkg/libpulse-4.0-6-x86_64.pkg.tar.xz /var/cache/pacman/pkg/lib32-libpulse-4.0-6-x86_64.pkg.tar.xz

Y así, si me dejo hacer el downgrade

:)
Avatar de Usuario
Cristian Moreno

Miembro
 
Mensajes: 157
Registrado: Jue, 19 Sep 2013, 01:47
Ubicación: Bogotá
Distro actual: Manjaro
Versión: 0.8.7.0
Escritorio: xfce


  • Temas Parecidos
    Respuestas
    Vistas
    Último mensaje

Volver a Juegos en Linux



¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 1 invitado




StaffBorrar las cookies


^ Ir Arriba