no puedo instalar desde yaourt  [Solucionado]

Las cuestiones relacionadas con el uso del Arch User Repository (AUR).
Reglas del Foro
Lea las normas y conductas de la comunidad en "Zona Normatividad".
Busca antes de preguntar en Google y en el buscador de este foro.
Si se soluciona tu problema presione el botón en V de color verde, Imagen, para añadir un [Solucionado].

no puedo instalar desde yaourt  [Solucionado]

Notapor nogayo » Mié, 25 Nov 2015, 14:52  •  [Mensaje 1]

holas gente...saludos a la distancia....mi consulta era sobre el yaourt.....trato de instalar programas desde el yaourt como el pgmodeler o el sublime-text y siempre me sale el siguiente error:

Código: Seleccionar todo
==> Continuar compilando pgmodeler? [S/n]
==> -------------------------------------
==>
==> Compilando e instalando el paquete
==> ERROR: No se pudo encontrar el binario openssl requerido para verificar las sumas de control de las fuentes.
==> ERROR: Makepkg no ha podido compilar pgmodeler.
==> ¿Reiniciar la compilación de pgmodeler? [s/N]


alguna sugerencia??? si no hay solucion estoy pensando en compilar directamente desde el AUR, pero nose por donde empezar, alguna info que me pueda ayudar al respecto?? o cual es mas recomendado, instalar desde el yaourt o hacerlo manualmente desde el AUR.....gracias por su tiempo

 ! Spooky escribió:
Tema movido al foro AUR
Avatar de Usuario
nogayo

Novato
 
Mensajes: 9
Registrado: Jue, 26 Mar 2015, 17:32
Distro actual: manjaro linux
Versión: 0.9.8
Escritorio: xfce
Rama: netbook edition

Re: no puedo instalar desde yaourt

Notapor Spooky » Mié, 25 Nov 2015, 17:11  •  [Mensaje 2]

Instala el paquete openssl, este es requerido para comprobar la integridad del paquete..

También puedes saltar la verificación usando la opción skipinteg, checa este tema:
viewtopic.php?t=180

Enviado desde mi SGH-I317M mediante Tapatalk
Avatar de Usuario
Spooky

Moderador
 
Mensajes: 1421
Registrado: Sab, 06 Jul 2013, 02:04
Ubicación: Behind your computer

Re: no puedo instalar desde yaourt

Notapor nogayo » Mié, 25 Nov 2015, 23:13  •  [Mensaje 3]

gracias por tu tiempo spooky...te cuento que ya tengo instalado el openssl :

Código: Seleccionar todo
pacman -Ss openssl
core/openssl 1.0.2.d-1 [instalado]
 The Open Source toolkit for Secure Sockets Layer and
 Transport Layer Security


y si deshabilito la verificacion......no estoy comprometiendo la integridad de mi sistema?? sabes a q se debe este problema?? es raro x q antes se instalaba normal los paquetes de yaourt....otra cosa...tendras por ahi un tuto o un tema donde se pueda ver el tema de compilar nuestro propio programa desde AUR...?? ..gracias por tu tiempo :)
Avatar de Usuario
nogayo

Novato
 
Mensajes: 9
Registrado: Jue, 26 Mar 2015, 17:32
Distro actual: manjaro linux
Versión: 0.9.8
Escritorio: xfce
Rama: netbook edition

Re: no puedo instalar desde yaourt

Notapor K|Ke » Mié, 25 Nov 2015, 23:27  •  [Mensaje 4]

Hola nogayo, revisa el siguiente link

Enlace

Saludos.
K|Ke
Manjaro Linux Comunidad Hispana
Administrador de Sistema

"Las personas nacen libres e iguales en dignidad y derechos"
Personal LiCo
Avatar de Usuario
K|Ke

Administrador
 
Mensajes: 1063
Registrado: Dom, 18 Ago 2013, 17:06
Ubicación: Región de Atacama - Chile
Distro actual: Arch y Manjaro Linux
Versión: Comunitaria
Escritorio: Fluxbox
Rama: Unstable

Re: no puedo instalar desde yaourt

Notapor Spooky » Mié, 25 Nov 2015, 23:55  •  [Mensaje 5]

No verificar un sha1sum o md5sum no es grave, grave sería ejecutar un script como root sin antes saber que estas haciendo..

Por otra parte es simple, de hecho en el mismo link que puse explico como compilar paquetes manualmente del repo AUR.


Enviado desde mi SGH-I317M mediante Tapatalk
Avatar de Usuario
Spooky

Moderador
 
Mensajes: 1421
Registrado: Sab, 06 Jul 2013, 02:04
Ubicación: Behind your computer

Re: no puedo instalar desde yaourt

Notapor nogayo » Jue, 26 Nov 2015, 01:05  •  [Mensaje 6]

muchas gracias por su tiempo, eternamente agradecido...te cuento spooky que no pude realizar esto:
Código: Seleccionar todo
makepkg --skipinteg

y eso q estoy en la carpeta descomprimida y me sale esto :

==> ERROR: PKGBUILD no existe.

trate de instalar el packer...tampoco se pudo...ayuda spooky...gracias de antemano
Avatar de Usuario
nogayo

Novato
 
Mensajes: 9
Registrado: Jue, 26 Mar 2015, 17:32
Distro actual: manjaro linux
Versión: 0.9.8
Escritorio: xfce
Rama: netbook edition

Re: no puedo instalar desde yaourt

Notapor Spooky » Jue, 26 Nov 2015, 01:30  •  [Mensaje 7]

Ni idea de que hayas descargado, debes descargar el snapshot:
https://aur.archlinux.org/packages/pgmodeler

Dirígete a las opciones que aparecen del lado derecho, ahí viene una opción llamada Download snapahot..

Automáticamente empezará a descargar un archivo con extensión .tar.gz, ese archivo debes descomprimirlo, luego saldrá un archivo con extensión .tar, lo descomprime de nuevo y listo, en esa carpeta esta el PKGBUILD.

Enviado desde mi SGH-I317M mediante Tapatalk
Avatar de Usuario
Spooky

Moderador
 
Mensajes: 1421
Registrado: Sab, 06 Jul 2013, 02:04
Ubicación: Behind your computer

Re: no puedo instalar desde yaourt

Notapor nogayo » Jue, 26 Nov 2015, 02:44  •  [Mensaje 8]

mil gracias spooky, ahora pude descargar y ejecutar...creo q el problema sera esperar...me imagino que esta compilando:

Código: Seleccionar todo
g++ -c -pipe -O2 -march=i686 -mtune=generic -O2 -pipe -fstack-protector-strong -std=c++0x -Wall -W -D_REENTRANT -fPIC -DBUILDNUM=\"20151125\" -DBINDIR=\"/usr/local/bin\" -DPLUGINSDIR=\"/usr/local/lib/pgmodeler/plugins\" -DPRIVATEBINDIR=\"/usr/local/lib/pgmodeler/bin\" -DCONFDIR=\"/usr/local/share/pgmodeler/conf\" -DDOCDIR=\"/usr/local/share/pgmodeler\" -DLANGDIR=\"/usr/local/share/pgmodeler/lang\" -DSAMPLESDIR=\"/usr/local/share/pgmodeler/samples\" -DSCHEMASDIR=\"/usr/local/share/pgmodeler/schemas\" -DQT_NO_DEBUG -DQT_PRINTSUPPORT_LIB -DQT_WIDGETS_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -I. -I../libobjrenderer/src -I../libpgconnector/src -I../libpgmodeler/src -I../libparsers/src -I../libutils/src -isystem /usr/include/libxml2 -isystem /usr/include/qt -isystem /usr/include/qt/QtPrintSupport -isystem /usr/include/qt/QtWidgets -isystem /usr/include/qt/QtGui -isystem /usr/include/qt/QtNetwork -isystem /usr/include/qt/QtCore -Imoc -Isrc -I/usr/lib/qt/mkspecs/linux-g++ -o obj/customsqlwidget.o src/customsqlwidget.cpp


gracias de antemano

== Editado en Mié, 25 Nov 2015, 22:32 ==

por fin......gracias kike y sobretodo muchisimas gracias spooky...realmente se pudo..... :lol: :lol: :mrgreen: :mrgreen: :mrgreen:
Avatar de Usuario
nogayo

Novato
 
Mensajes: 9
Registrado: Jue, 26 Mar 2015, 17:32
Distro actual: manjaro linux
Versión: 0.9.8
Escritorio: xfce
Rama: netbook edition


  • Temas Parecidos
    Respuestas
    Vistas
    Último mensaje

Volver a AUR



¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 1 invitado




StaffBorrar las cookies


^ Ir Arriba