No arranca el login manager SLIM  [Solucionado]

Temas generales sobre el OpenBox.
Reglas del Foro
Lea las normas y conductas de la comunidad en "Zona Normatividad".
Busca antes de preguntar en Google y en el buscador de este foro.
Si se soluciona tu problema presione el botón en V de color verde, Imagen, para añadir un [Solucionado].

No arranca el login manager SLIM

Notapor JazielRT » Mié, 16 Abr 2014, 17:54  •  [Mensaje 1]

 ! K|Ke escribió:
Tema movido desde el Foro GNU/Linux y otras distribuciones al Foro Escritorios Oficiales, Subforo Openbox por corresponder a este último.


Saludos comunidad,
soy nuevo aquí y me he animado a extornar mi problema porque ya llevo dos días intentando resolverlo. No tengo idea de como sucedió pero un día prendí la maquina y lo inicio sesión automáticamente (como había sucedido siempre) solo era la pantalla negra con la siguiente información:
Código: Seleccionar todo
Manjaro Linux 3.10.36-1-MANJARO (NombreDeMaquina)(tt1)
NombreDeMaquina login:

Hice el login con mi usuario y mi contraseña pero como es de esperar solo inicio sesion en modo consola así que ejecute:
Código: Seleccionar todo
startx
y así ya entré (y sigo entrando) al modo gráfico sin ningún problema.
Inmediatamente abrí la terminal, desinstale Slim y lo instale de nuevo (soy ingenuo, denme chance):
Código: Seleccionar todo
sudo pacman -S slim

sin embargo (como era de esperar) no paso nada, investigue en internet y se supone debo editar ~/.xinitrc (sin embargo estaba todo como debería estar, según yo)
Este es mi ~/.xinitrc:
Código: Seleccionar todo
#!/bin/sh

#
# ~/.xinitrc
#
# Executed by startx (run your window manager from here)
#
# Written by Phil Muller


## Ensure that the D-Bus Communication System is running properly to fix
## File management, authentication, and other essential system processes

if which dbus-launch >/dev/null && test -z "$DBUS_SESSION_BUS_ADDRESS"; then
    eval "$(dbus-launch --sh-syntax --exit-with-session)"
fi


## Ensure that GTK themes are applied uniformly in the Desktop Environment

export GTK2_RC_FILES="$HOME/.gtkrc-2.0"


## Where the default Home folders have not already been created, generate them

if [ -x /usr/bin/xdg-user-dirs-update ]; then
   /usr/bin/xdg-user-dirs-update
fi

## Ensure that obmenu-generator (a pipe menu) is set to the user.
## Does this for each session (i.e. ease of use for addtional
## accounts where created.

sed 's/_user_/'$(whoami)'/' ~/.config/obmenu-generator/schema.pl -i
sed 's/_user_/'$(whoami)'/' ~/.config/obmenu-generator/config.pl -i


## Enable SLiM to enable selection of multiple desktop environments, or
## set a single session. Only one or the other must be unhashed! In either
## instance, /etc/slim.conf must also be amended accordingly.

## Enable multiple desktop environments
exec $1
## Set a single desktop environment
exec openbox-session
#exec xfce4-session
#exec gnome-session
#exec startkde
#exec cinnamon-session
#exec razor-session
#exec lxsession
#exec mate-session


Este es mi /etc/slim.conf:
Código: Seleccionar todo
# Path, X server and arguments (if needed)
# Note: -xauth $authfile is automatically appended
default_path        /bin:/usr/bin:/usr/local/bin
default_xserver     /usr/bin/X
xserver_arguments -nolisten tcp vt07

# Commands for halt, login, etc.
halt_cmd            /sbin/shutdown -h now
reboot_cmd          /sbin/shutdown -r now
console_cmd         /usr/bin/xterm -C -fg white -bg black +sb -T "Console login" -e /bin/sh -c "/bin/cat /etc/issue; exec /bin/login"
#suspend_cmd        /usr/sbin/suspend

# Full path to the xauth binary
xauth_path         /usr/bin/xauth

# Xauth file for server
authfile           /var/run/slim.auth


# Activate numlock when slim starts. Valid values: on|off
# numlock             on

# Hide the mouse cursor (note: does not work with some WMs).
# Valid values: true|false
# hidecursor          false

# This command is executed after a succesful login.
# you can place the %session and %theme variables
# to handle launching of specific commands in .xinitrc
# depending of chosen session and slim theme
#
# NOTE: if your system does not have bash you need
# to adjust the command according to your preferred shell,
# i.e. for freebsd use:
# login_cmd           exec /bin/sh - ~/.xinitrc %session
login_cmd           exec /bin/bash -login ~/.xinitrc %session

# Commands executed when starting and exiting a session.
# They can be used for registering a X11 session with
# sessreg. You can use the %user variable
#
# sessionstart_cmd   some command
# sessionstop_cmd   some command

# Start in daemon mode. Valid values: yes | no
# Note that this can be overriden by the command line
# options "-d" and "-nodaemon"
# daemon   yes

# Set directory that contains the xsessions.
# slim reads xsesion from this directory, and be able to select.
sessiondir            /usr/share/xsessions/

# Executed when pressing F11 (requires imagemagick)
screenshot_cmd      import -window root /slim.png

# welcome message. Available variables: %host, %domain
welcome_msg         Welcome to %host

# Session message. Prepended to the session name when pressing F1
# session_msg         Session:

# shutdown / reboot messages
shutdown_msg       The system is halting...
reboot_msg         The system is rebooting...

# default user, leave blank or remove this line
# for avoid pre-loading the username.
#default_user        simone

# Focus the password field on start when default_user is set
# Set to "yes" to enable this feature
#focus_password      no

# Automatically login the default user (without entering
# the password. Set to "yes" to enable this feature
#auto_login          no


# current theme, use comma separated list to specify a set to
# randomly choose from
current_theme       default

# Lock file
lockfile            /var/lock/slim.lock

# Log file
logfile             /var/log/slim.log



En algunas paginas vi que debo editar el archivo "/etc/inittab" o agregar el domonio al vector en /etc/rc.conf pero no tengo ninguno de esos dos archivos así que ya no se que como solucionar mi problema, espero y puedan ayudarme. Gracias de antemano. :D
Avatar de Usuario
JazielRT

Novato
 
Mensajes: 5
Registrado: Sab, 12 Abr 2014, 17:22
Distro actual: Manjaro
Versión: 0.8.9
Escritorio: Openbox
Rama: stable

Re: No arranca el login manager SLIM

Notapor K|Ke » Mié, 16 Abr 2014, 18:48  •  [Mensaje 2]

Copia y pega lo que te indica el comando

Código: Seleccionar todo
sudo systemctl status slim


Saludos.
K|Ke
Manjaro Linux Comunidad Hispana
Administrador de Sistema

"Las personas nacen libres e iguales en dignidad y derechos"
Personal LiCo
Avatar de Usuario
K|Ke

Administrador
 
Mensajes: 1069
Registrado: Dom, 18 Ago 2013, 17:06
Ubicación: Región de Atacama - Chile
Distro actual: Arch y Manjaro Linux
Versión: Comunitaria
Escritorio: Fluxbox
Rama: Unstable

Re: No arranca el login manager SLIM

Notapor Spooky » Mié, 16 Abr 2014, 19:15  •  [Mensaje 3]

Aparte de lo que ya te comentaron y únicamente como nota, esos ficheros no existen ya que pertenecen a initscripts..
Arch Linux hace ya bastante que abandono initscripts para migrar a systemd.
Avatar de Usuario
Spooky

Moderador
 
Mensajes: 1422
Registrado: Sab, 06 Jul 2013, 02:04
Ubicación: Behind your computer

Re: No arranca el login manager SLIM

Notapor JazielRT » Mié, 16 Abr 2014, 20:56  •  [Mensaje 4]

K|Ke escribió:Copia y pega lo que te indica el comando

Código: Seleccionar todo
sudo systemctl status slim


Saludos.


Saudos, ejecute el comando y esta fue la respuesta:
Código: Seleccionar todo
● slim.service - SLiM Simple Login Manager
   Loaded: loaded (/usr/lib/systemd/system/slim.service; disabled)
   Active: inactive (dead)
Avatar de Usuario
JazielRT

Novato
 
Mensajes: 5
Registrado: Sab, 12 Abr 2014, 17:22
Distro actual: Manjaro
Versión: 0.8.9
Escritorio: Openbox
Rama: stable

Re: No arranca el login manager SLIM

Notapor K|Ke » Mié, 16 Abr 2014, 21:55  •  [Mensaje 5]

JazielRT escribió:
K|Ke escribió:Copia y pega lo que te indica el comando

Código: Seleccionar todo
sudo systemctl status slim


Saludos.


Saudos, ejecute el comando y esta fue la respuesta:
Código: Seleccionar todo
● slim.service - SLiM Simple Login Manager
   Loaded: loaded (/usr/lib/systemd/system/slim.service; disabled)
   Active: inactive (dead)


Ok, entonces haz lo siguiente

Código: Seleccionar todo
sudo systemctl enable slim


Luego reinicia la máquina.

Saludos.
K|Ke
Manjaro Linux Comunidad Hispana
Administrador de Sistema

"Las personas nacen libres e iguales en dignidad y derechos"
Personal LiCo
Avatar de Usuario
K|Ke

Administrador
 
Mensajes: 1069
Registrado: Dom, 18 Ago 2013, 17:06
Ubicación: Región de Atacama - Chile
Distro actual: Arch y Manjaro Linux
Versión: Comunitaria
Escritorio: Fluxbox
Rama: Unstable

Re: No arranca el login manager SLIM

Notapor JazielRT » Mié, 16 Abr 2014, 23:26  •  [Mensaje 6]

K|Ke escribió:
JazielRT escribió:
K|Ke escribió:Copia y pega lo que te indica el comando

Ok, entonces haz lo siguiente

Código: Seleccionar todo
sudo systemctl enable slim


Luego reinicia la máquina.

Saludos.


Cuando ejecuto el comando me arroja este resultado:
Código: Seleccionar todo
Failed to execute operation: File exists

:(
Avatar de Usuario
JazielRT

Novato
 
Mensajes: 5
Registrado: Sab, 12 Abr 2014, 17:22
Distro actual: Manjaro
Versión: 0.8.9
Escritorio: Openbox
Rama: stable

Re: No arranca el login manager SLIM

Notapor K|Ke » Mié, 16 Abr 2014, 23:39  •  [Mensaje 7]

Supongo que no has instalado otro gestor de arranque, bueno luego me dices

Haz lo siguiente

Código: Seleccionar todo
sudo systemctl disable slim.service


Luego lo habilitas nuevamente y prueba

Código: Seleccionar todo
sudo systemctl enable slim.service


Sí aún así no va, entonces fuerza el inicio del servicio

Código: Seleccionar todo
sudo systemctl enable slim.service -f
K|Ke
Manjaro Linux Comunidad Hispana
Administrador de Sistema

"Las personas nacen libres e iguales en dignidad y derechos"
Personal LiCo
Avatar de Usuario
K|Ke

Administrador
 
Mensajes: 1069
Registrado: Dom, 18 Ago 2013, 17:06
Ubicación: Región de Atacama - Chile
Distro actual: Arch y Manjaro Linux
Versión: Comunitaria
Escritorio: Fluxbox
Rama: Unstable

Re: No arranca el login manager SLIM

Notapor JazielRT » Jue, 17 Abr 2014, 06:59  •  [Mensaje 8]

K|Ke escribió:Supongo que no has instalado otro gestor de arranque, bueno luego me dices

Haz lo siguiente

Código: Seleccionar todo
sudo systemctl disable slim.service


Luego lo habilitas nuevamente y prueba

Código: Seleccionar todo
sudo systemctl enable slim.service


Sí aún así no va, entonces fuerza el inicio del servicio

Código: Seleccionar todo
sudo systemctl enable slim.service -f


Perdón, se me olvido mencionar que instale "lxdm" después de tener este problema, lxdm arranco pero no reconocía la combinación de usuario y contraseña así que lo desinstale y fue cuando me di por vencido. Luego hice este tema en el foro xD

Ya ejecute los comandos y despues de forzar el inicio del servicio me apareció esto:
Código: Seleccionar todo
ln -s '/usr/lib/systemd/system/slim.service' '/etc/systemd/system/display-manager.service'

Pero aún así no inicia el condenado Slim :(
Avatar de Usuario
JazielRT

Novato
 
Mensajes: 5
Registrado: Sab, 12 Abr 2014, 17:22
Distro actual: Manjaro
Versión: 0.8.9
Escritorio: Openbox
Rama: stable

Re: No arranca el login manager SLIM  [Solucionado]

Notapor K|Ke » Jue, 17 Abr 2014, 15:12  •  [Mensaje 9]

JazielRT escribió:Perdón, se me olvido mencionar que instale "lxdm" después de tener este problema, lxdm arranco pero no reconocía la combinación de usuario y contraseña así que lo desinstale y fue cuando me di por vencido. Luego hice este tema en el foro xD

Ya ejecute los comandos y despues de forzar el inicio del servicio me apareció esto:
Código: Seleccionar todo
ln -s '/usr/lib/systemd/system/slim.service' '/etc/systemd/system/display-manager.service'

Pero aún así no inicia el condenado Slim :(


Probemos lo siguiente:

1er. paso
Código: Seleccionar todo
sudo systemctl disable lxdm.service


2do. paso
Código: Seleccionar todo
sudo pacman -Rns lxdm


3er. paso
Código: Seleccionar todo
sudo pacman -S slim


4to. paso
Código: Seleccionar todo
sudo systemctl enable slim.service


5to. paso
Código: Seleccionar todo
sudo reboot


Y luego me indicas que ocurre.

Saludos.
K|Ke
Manjaro Linux Comunidad Hispana
Administrador de Sistema

"Las personas nacen libres e iguales en dignidad y derechos"
Personal LiCo
Avatar de Usuario
K|Ke

Administrador
 
Mensajes: 1069
Registrado: Dom, 18 Ago 2013, 17:06
Ubicación: Región de Atacama - Chile
Distro actual: Arch y Manjaro Linux
Versión: Comunitaria
Escritorio: Fluxbox
Rama: Unstable

Re: No arranca el login manager SLIM

Notapor JazielRT » Jue, 17 Abr 2014, 19:10  •  [Mensaje 10]

Gracias a todos por su ayuda.
K|Ke, ha funcionado lo que me has dicho :)
Avatar de Usuario
JazielRT

Novato
 
Mensajes: 5
Registrado: Sab, 12 Abr 2014, 17:22
Distro actual: Manjaro
Versión: 0.8.9
Escritorio: Openbox
Rama: stable


  • Temas Parecidos
    Respuestas
    Vistas
    Último mensaje

Volver a OpenBox



¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 1 invitado




StaffBorrar las cookies


cron
^ Ir Arriba