Problema al actualizar

Problemas, sugerencias sobre la instalación y actualización de Manjaro. Consulta antes de instalar.
Reglas del Foro
Lea las normas y conductas de la comunidad en "Zona Normatividad".
Busca antes de preguntar en Google y en el buscador de este foro.
Si se soluciona tu problema presione el botón en V de color verde, Imagen, para añadir un [Solucionado].

Problema al actualizar

Notapor janopi » Vie, 31 Mar 2017, 22:47  •  [Mensaje 1]

Estimados, hace mucho que no tenia conexion a internet y Octopi me dice ahora que hay mas de 600 y tantas actualizaciones. Estoy en KDE 16.10 todavia y la idea es actualizar al 17 que se lanzó hace poco. Al intentar actualizar via Octopi sale lo siguiente

Código: Seleccionar todo
:: Iniciando actualización completa del sistema…
:: ¿Remplazar calligra-filters con extra/calligra?  [S/n] s
:: ¿Remplazar calligra-karbon con extra/calligra?  [S/n] s
:: ¿Remplazar calligra-l10n-es con extra/calligra?  [S/n] s
:: ¿Remplazar calligra-libs con extra/calligra?  [S/n] s
:: ¿Remplazar calligra-plugins con extra/calligra?  [S/n] s
:: ¿Remplazar cdrkit con community/cdrtools?  [S/n] s
:: ¿Remplazar fuse con extra/fuse2?  [S/n] s
:: ¿Remplazar kdebase-kdialog con extra/kdialog?  [S/n] s
:: ¿Remplazar kdebase-keditbookmarks con extra/keditbookmarks?  [S/n] s
:: ¿Remplazar kdebase-kfind con extra/kfind?  [S/n] s
:: ¿Remplazar kdegraphics-okular con extra/okular?  [S/n] s
:: ¿Remplazar konsolekalendar con extra/akonadi-calendar-tools?  [S/n] s
:: ¿Remplazar ktnef con extra/kmail?  [S/n] s
:: ¿Remplazar libastro con extra/marble-common?  [S/n] s
:: ¿Remplazar manjaro-welcome con extra/manjaro-hello?  [S/n] s
sresolviendo dependencias…
buscando conflictos entre paquetes…
:: calligra y calligra-braindump están en conflicto. ¿Quitar calligra-braindump? [s/N] s
:: marble-common y libmarble4 están en conflicto (kdeedu-marble). ¿Quitar libmarble4? [s/N] s
:: kmail-account-wizard y kdepim-common están en conflicto. ¿Quitar kdepim-common? [s/N] s
:: xorg-server y xf86-input-acecad están en conflicto (X-ABI-XINPUT_VERSION). ¿Quitar xf86-input-acecad? [s/N] s
:: xorg-server y xf86-input-joystick están en conflicto (X-ABI-XINPUT_VERSION). ¿Quitar xf86-input-joystick? [s/N] s
error: no se pudo preparar la operación (no se pudieron satisfacer las dependencias)
:: libkgeomap4: quitando «libmarble4» se rompe la dependencia con «libmarble4»


Y de ahi se cierra y vuelve a empezar y de nuevo lo mismo.

Probé también con una solución que me dieron hace un tiempo que era
Código: Seleccionar todo
sudo pacman-key --refresh-keys

Y después,
Código: Seleccionar todo
sudo pacman -Syyu



Y sale lo siguiente:

Código: Seleccionar todo
sudo pacman -Syyu   
:: Sincronizando las bases de datos de los paquetes…
 core                                                                       137,2 KiB   129K/s 00:01 [############################################################] 100%
 extra                                                                     1778,9 KiB   152K/s 00:12 [############################################################] 100%
 community                                                                    4,1 MiB   271K/s 00:15 [############################################################] 100%
:: Iniciando actualización completa del sistema…
:: ¿Remplazar calligra-filters con extra/calligra?  [S/n] s
:: ¿Remplazar calligra-karbon con extra/calligra?  [S/n] s
:: ¿Remplazar calligra-l10n-es con extra/calligra?  [S/n] s
:: ¿Remplazar calligra-libs con extra/calligra?  [S/n] s
:: ¿Remplazar calligra-plugins con extra/calligra?  [S/n] s
:: ¿Remplazar cdrkit con community/cdrtools?  [S/n] s
:: ¿Remplazar fuse con extra/fuse2?  [S/n] s
:: ¿Remplazar kdebase-kdialog con extra/kdialog?  [S/n] s
:: ¿Remplazar kdebase-keditbookmarks con extra/keditbookmarks?  [S/n] s
:: ¿Remplazar kdebase-kfind con extra/kfind?  [S/n] s
:: ¿Remplazar kdegraphics-okular con extra/okular?  [S/n] s
:: ¿Remplazar konsolekalendar con extra/akonadi-calendar-tools?  [S/n] s
:: ¿Remplazar ktnef con extra/kmail?  [S/n] s
:: ¿Remplazar libastro con extra/marble-common?  [S/n] s
:: ¿Remplazar manjaro-welcome con extra/manjaro-hello?  [S/n] s
resolviendo dependencias…
buscando conflictos entre paquetes…
:: calligra y calligra-braindump están en conflicto. ¿Quitar calligra-braindump? [s/N] s
:: marble-common y libmarble4 están en conflicto (kdeedu-marble). ¿Quitar libmarble4? [s/N] s
:: kmail-account-wizard y kdepim-common están en conflicto. ¿Quitar kdepim-common? [s/N] s
:: xorg-server y xf86-input-acecad están en conflicto (X-ABI-XINPUT_VERSION). ¿Quitar xf86-input-acecad? [s/N] s
:: xorg-server y xf86-input-joystick están en conflicto (X-ABI-XINPUT_VERSION). ¿Quitar xf86-input-joystick? [s/N] s
error: no se pudo preparar la operación (no se pudieron satisfacer las dependencias)
:: libkgeomap4: quitando «libmarble4» se rompe la dependencia con «libmarble4»

Al final probé dici9endole que no a las que destaca la N y se cierra:

[piluc@piluc-pc ~]$     sudo pacman -Syyu
:: Sincronizando las bases de datos de los paquetes…
 core                                                                       137,2 KiB   280K/s 00:00 [############################################################] 100%
 extra                                                                     1778,9 KiB   243K/s 00:07 [############################################################] 100%
 community                                                                    4,1 MiB   175K/s 00:24 [############################################################] 100%
:: Iniciando actualización completa del sistema…
:: ¿Remplazar calligra-filters con extra/calligra?  [S/n] s
:: ¿Remplazar calligra-karbon con extra/calligra?  [S/n] s
:: ¿Remplazar calligra-l10n-es con extra/calligra?  [S/n] s
:: ¿Remplazar calligra-libs con extra/calligra?  [S/n] s
:: ¿Remplazar calligra-plugins con extra/calligra?  [S/n] s
:: ¿Remplazar cdrkit con community/cdrtools?  [S/n] s
:: ¿Remplazar fuse con extra/fuse2?  [S/n] s
:: ¿Remplazar kdebase-kdialog con extra/kdialog?  [S/n] s
:: ¿Remplazar kdebase-keditbookmarks con extra/keditbookmarks?  [S/n] s
:: ¿Remplazar kdebase-kfind con extra/kfind?  [S/n] s
:: ¿Remplazar kdegraphics-okular con extra/okular?  [S/n] s
:: ¿Remplazar konsolekalendar con extra/akonadi-calendar-tools?  [S/n] s
:: ¿Remplazar ktnef con extra/kmail?  [S/n] s
:: ¿Remplazar libastro con extra/marble-common?  [S/n] s
:: ¿Remplazar manjaro-welcome con extra/manjaro-hello?  [S/n] s
resolviendo dependencias…
buscando conflictos entre paquetes…
:: calligra y calligra-braindump están en conflicto. ¿Quitar calligra-braindump? [s/N] n
error: se han detectado paquetes con conflictos irresolubles
error: no se pudo preparar la operación (dependencias en conflicto)
:: calligra y calligra-braindump están en conflicto


¿Qué puede ser? Les agradecería ayuda para solucionar este problema. Saludos y gracias

 ! Spooky escribió:
Favor de usar las etiquetas code.
Avatar de Usuario
janopi

Aprendiz
 
Mensajes: 17
Registrado: Dom, 06 Mar 2016, 04:39
Distro actual: Manjaro
Versión: 15.2
Escritorio: kde
Rama: stable

Re: Problema al actualizar

Notapor Spooky » Sab, 01 Abr 2017, 03:58  •  [Mensaje 2]

Elimina el paquete que causa el conflicto, actualiza, y si aun requieres el paquete lo instalas de nuevo:
Código: Seleccionar todo
sudo pacman -R libkgeomap4
sudo pacman -Syu
sudo pacman -S libkgeomap
Avatar de Usuario
Spooky

Moderador
 
Mensajes: 1422
Registrado: Sab, 06 Jul 2013, 02:04
Ubicación: Behind your computer

Re: Problema al actualizar

Notapor janopi » Dom, 02 Abr 2017, 00:12  •  [Mensaje 3]

Gracias Spooky. Como siempre ayudando. Hice lo que me indicaste y efectivamente corrió la actualización. El problema es que después de bajar todas esas actualizaciones me arrojó un error y no actualizó el sistema. Ahora vuelvo a intentarlo y me sale lo siguiente, que espero salga como código


Tamaño total de la instalación: 6217,81 MiB
Tamaño neto tras actualizar: 287,96 MiB
Código: Seleccionar todo
:: ¿Continuar con la instalación? [S/n] s
(730/730) comprobando las claves del depósito                                    [##############################################] 100%
(730/730) verificando la integridad de los paquetes                              [##############################################] 100%
(730/730) cargando los archivos de los paquetes                                  [##############################################] 100%
(730/730) comprobando conflictos entre archivos                                  [##############################################] 100%
error: no se pudo realizar la operación (archivos en conflicto)
xorg-server: /usr/lib/xorg/modules/extensions/libglx.so existe en el sistema de archivos
Ocurrieron errores, por lo que no se actualizaron los paquetes


Intenté borrar libglx.so con sudo pacman -R pero me dice "destino no encontrado". Seguí la ruta y el archivo existe pero no se puede borrar. ¿Qué puede ser? No quiero cometer algún error así que prefiero volver a preguntar. Agradecido de antemano.

Saludos
Avatar de Usuario
janopi

Aprendiz
 
Mensajes: 17
Registrado: Dom, 06 Mar 2016, 04:39
Distro actual: Manjaro
Versión: 15.2
Escritorio: kde
Rama: stable

Re: Problema al actualizar

Notapor Spooky » Dom, 02 Abr 2017, 01:02  •  [Mensaje 4]

En esos casos siempre puedes cambiar el archivo para asi poder continuar con la instalacion.
Código: Seleccionar todo
sudo mv  /usr/lib/xorg/modules/extensions/libglx.so  /usr/lib/xorg/modules/extensions/libglx.so.backup

Con eso lo que estas haciendo es simplemente cambiar el nombre de la extension, lo cual no genera ningun problema.

Saludos
Avatar de Usuario
Spooky

Moderador
 
Mensajes: 1422
Registrado: Sab, 06 Jul 2013, 02:04
Ubicación: Behind your computer

Re: Problema al actualizar

Notapor janopi » Lun, 10 Abr 2017, 22:53  •  [Mensaje 5]

Gracias Spooky. Ahí sí funcionó. Actualizó el sistema y ya estamos con Manjaro 17 en KDE. Lo único que sigo sin resolver es la actualización de gstreamer 0.10 que aparece dentro de las actualizaciones, pero que no se cómo resolver. Esto es lo que sale.

Código: Seleccionar todo
==> Descargando PKGBUILD para gstreamer0.10-base desde AUR...
x .SRCINFO
x PKGBUILD
x ayuv64-lanczos.patch
x colorbalance-fix-abi.patch
x fix-crash-0-byte-ogg.patch
x gstaudio-symbols.patch
x revert-decodebin-playbin-removal.patch
x videoscale-fix-negotiation.patch
obarun commented on 2017-03-05 10:48                     
hello nicepack,
please make the change about .SRCINFO, this is break all automatic intallation.
Thanks in advance

ata commented on 2017-03-11 22:35                       
== Starting build()...
/tmp/yaourt-tmp-ata/aur-gstreamer0.10/./PKGBUILD: line 29: ./autogen.sh: Permission denied
== ERROR: A failure occurred in build().
Aborting...
== ERROR: Makepkg was unable to build gstreamer0.10.
== Restart building gstreamer0.10 ? [y/N]
== --------------------------------------
==

cmsigler commented on 2017-03-14 16:07                   
@ata                                                                                                                                                                   
Build WFM on x86_64.                                                                                                                                                   
                                                                                                                                                                       
When you get "Permission denied" it normally means the execute permission bit(s) are not set for that file, so the shell refuses to run it.  Try running makepkg on this AUR again.  Maybe there was a weird hiccup during git checkout from the repository?                                                                                   
                                                                                                                                                                       
Clemmitt                                                                                                                                                               
                                                                                                                                                                       
Goldman60 commented on 2017-03-22 01:24                                                                                                                                 
It appears that make runs successfully under pacaur but it doesn't properly install                                                                                     
                                                                                                                                                                       
benoliver999 commented on 2017-03-24 07:38                                                                                                                             
The .SRCINFO really could do with sorting. I think pacaur reports the correct error, but other helpers break randomly, for instance it causes apacman to 'wait' before installing (but it never happens).                                                                                                                                       
                                                                                                                                                                       
gstreamer0.10-base 0.10.36-9  (2017-02-20 13:18)                                                                                                                       
(Paquete sin soporte: ¡podría ser peligroso!)
==> ¿Quiere editar PKGBUILD? [S/n] ("A" para anular)
==> ------------------------------------------------
==> s

Por favor, añada $VISUAL  a las variables de entorno
por ejemplo:
export VISUAL="vim" (en ~/.bashrc)
(remplace vim por su editor preferido)

==> Editar PKGBUILD con:


Y hasta ahí llego. Lei por ahi algunas cosas respecto a gstreamer que están en inglés así que pero prefiero preguntar acá en el foro. Espero me puedas ayudar.

Agradecido de antemano
Avatar de Usuario
janopi

Aprendiz
 
Mensajes: 17
Registrado: Dom, 06 Mar 2016, 04:39
Distro actual: Manjaro
Versión: 15.2
Escritorio: kde
Rama: stable

Re: Problema al actualizar

Notapor Mexxz » Mar, 11 Abr 2017, 01:46  •  [Mensaje 6]

No actualices ningún programa que pida gstreamer0.10 (es una librería obsoleta)
Avatar de Usuario
Mexxz

Aprendiz
 
Mensajes: 34
Registrado: Mié, 08 Feb 2017, 02:44
Distro actual: Manjaro
Versión: 17.0.2
Escritorio: Varios
Rama: testing

Re: Problema al actualizar

Notapor MZ17 » Lun, 17 Abr 2017, 17:36  •  [Mensaje 7]

gstreamer lo puedes ir borrando sin mayor problema.
Avatar de Usuario
MZ17

Aprendiz
 
Mensajes: 10
Registrado: Lun, 31 Ago 2015, 18:44
Distro actual: Manjaro Linux
Versión: Manjaro 17.0.1
Escritorio: KDE
Rama: Stable

Re: Problema al actualizar

Notapor janopi » Vie, 21 Abr 2017, 14:37  •  [Mensaje 8]

Vale, gracias. Lo borré. Solamente me quedan estos 3:

musicbrainz 2.1.5-7 2.1.5-8
qtwebkit 2.3.4-4 2.3.4-5
ttf-oxygen
1:5.4.3-2
1:5.4.3-3

== Editado en Vie, 21 Abr 2017, 09:39 ==

Se fue el mensaje. Les contaba que esos 3 quedan por actualizar y dan errores al compilar asi que no se si borrarlos tambien como el gstreamer o no. Es lo único que falta. Se agradece toda la ayuda.

saludos
Avatar de Usuario
janopi

Aprendiz
 
Mensajes: 17
Registrado: Dom, 06 Mar 2016, 04:39
Distro actual: Manjaro
Versión: 15.2
Escritorio: kde
Rama: stable


  • Temas Parecidos
    Respuestas
    Vistas
    Último mensaje

Volver a Instalación y actualizaciones



¿Quién está conectado?

Usuarios navegando por este Foro: Google [Bot] y 1 invitado




StaffBorrar las cookies


^ Ir Arriba