Imposible actualizar Manjaro

Problemas, sugerencias sobre la instalación y actualización de Manjaro. Consulta antes de instalar.
Reglas del Foro
Lea las normas y conductas de la comunidad en "Zona Normatividad".
Busca antes de preguntar en Google y en el buscador de este foro.
Si se soluciona tu problema presione el botón en V de color verde, Imagen, para añadir un [Solucionado].

Imposible actualizar Manjaro

Notapor Martinvk172 » Mar, 16 May 2017, 01:21  •  [Mensaje 1]

Hola! Hoy me encuentro con un problema que no se como resolver.
Cuando voy a actualizar, ya sea desde la consola con pacman -Syu , o desde Octopi, se da un error.
Está es la salida de pacman -Syu

Código: Seleccionar todo
udo pacman -Syu
[sudo] password for martin:
:: Sincronizando las bases de datos de los paquetes…
error: no se pudo obtener el archivo «core.db» desde jaran.undip.ac.id: Connection timed out after 10000 milliseconds
 core está actualizado
error: no se pudo obtener el archivo «extra.db» desde jaran.undip.ac.id: Connection timed out after 10001 milliseconds
 extra está actualizado
error: no se pudo obtener el archivo «community.db» desde jaran.undip.ac.id: Connection timed out after 10000 milliseconds
 community está actualizado
error: no se pudo obtener el archivo «multilib.db» desde jaran.undip.ac.id: Connection timed out after 10000 milliseconds
 multilib está actualizado
:: Iniciando actualización completa del sistema…
resolviendo dependencias…
buscando conflictos entre paquetes…
error: no se pudo preparar la operación (no se pudieron satisfacer las dependencias)
:: gstreamer0.10-good-plugins: instalando «libsoup» (2.58.1-1) se rompe la dependencia con «libsoup-gnome»
[martin@martin-linux ~]$
 

Por lo que veo es un problema de dependencias, pero no se como resolverlo. Alguien me puede ayudar?? Muchas gracias!!
Avatar de Usuario
Martinvk172

Novato
 
Mensajes: 3
Registrado: Mar, 16 May 2017, 01:18
Distro actual: Manjaro
Versión: .
Escritorio: Kde
Rama: Stable

Re: Imposible actualizar Manjaro

Notapor Spooky » Mar, 16 May 2017, 04:45  •  [Mensaje 2]

Primero cambia los mirrors, aquí en el foro está más que comentado lo anterior, si no también en el wiki encuentras cómo hacerlo.

Luego remueve gstreamer y actualiza.

Enviado desde mi HUAWEI TAG-L13 mediante Tapatalk
Avatar de Usuario
Spooky

Moderador
 
Mensajes: 1422
Registrado: Sab, 06 Jul 2013, 02:04
Ubicación: Behind your computer

Re: Imposible actualizar Manjaro

Notapor karlitozebc » Mar, 16 May 2017, 18:54  •  [Mensaje 3]

Martinvk172 escribió:Hola! Hoy me encuentro con un problema que no se como resolver.
Cuando voy a actualizar, ya sea desde la consola con pacman -Syu , o desde Octopi, se da un error.
Está es la salida de pacman -Syu

Código: Seleccionar todo
udo pacman -Syu
[sudo] password for martin:
:: Sincronizando las bases de datos de los paquetes…
error: no se pudo obtener el archivo «core.db» desde jaran.undip.ac.id: Connection timed out after 10000 milliseconds
 core está actualizado
error: no se pudo obtener el archivo «extra.db» desde jaran.undip.ac.id: Connection timed out after 10001 milliseconds
 extra está actualizado
error: no se pudo obtener el archivo «community.db» desde jaran.undip.ac.id: Connection timed out after 10000 milliseconds
 community está actualizado
error: no se pudo obtener el archivo «multilib.db» desde jaran.undip.ac.id: Connection timed out after 10000 milliseconds
 multilib está actualizado
:: Iniciando actualización completa del sistema…
resolviendo dependencias…
buscando conflictos entre paquetes…
error: no se pudo preparar la operación (no se pudieron satisfacer las dependencias)
:: gstreamer0.10-good-plugins: instalando «libsoup» (2.58.1-1) se rompe la dependencia con «libsoup-gnome»
[martin@martin-linux ~]$
 

Por lo que veo es un problema de dependencias, pero no se como resolverlo. Alguien me puede ayudar?? Muchas gracias!!


Hola, el fin de semana me pasó eso y yo lo que hice fue:

Actualizar por gestor gráfico de actualizaciones (manjaro-deepin es mi distro)
Pero le di click (descheck) a la casilla de verificación de "libsoup", para que no actualice esta librería.
El resto de la actualización, fue sin problema.
Una vez actualizo todo menos esa libsoup, cerré el gestor, fui a octopi y desinstale todo el gstreamer 0.10 (que es el antiguo) y deje solo el gstreamer reciente (gst-plugins-xxxx; gst-....).
Volví a abrir el gestor de actualizaciones y ya en ese momento si me dejo actualizar "libsoup" sin ningún problema.

https://wiki.archlinux.org/index.php/GS ... pa%C3%B1ol)

NOTA IMPORTANTE:
Lea el link primero, allí están todas las gstreamer nuevas que debe dejar, y todas las gstreamer 0.10 (viejas) que debe quitar, en resumen: quite todo lo que tenga gstreamer 0.10, y deje todo lo que tenga gst-xxxx.

Cuéntenos si le sirvió la ayuda, gracias
Avatar de Usuario
karlitozebc

Aprendiz
 
Mensajes: 28
Registrado: Mié, 10 Feb 2016, 02:53
Distro actual: Manjaro-Deepin
Versión: 17.0.2
Escritorio: Deepin
Rama: Stable

Re: Imposible actualizar Manjaro

Notapor 1persona » Jue, 18 May 2017, 20:49  •  [Mensaje 4]

estoy en la misma !
Uso kde
Código: Seleccionar todo
sudo pacman-mirrors -g
, pero no paso nada !
Error: no se pudo preparar la operación (no se pudieron satisfacer las dependencias)
:: gstreamer0.10-good-plugins: instalando «libsoup» (2.58.1-1) se rompe la dependencia con «libsoup-gnome»


ya encontraron la solucion?
Mi nivel de Linux en medio , medio bajo

Desde ya mucha gracias!
Avatar de Usuario
1persona

Miembro
 
Mensajes: 159
Registrado: Sab, 19 Oct 2013, 20:35
Distro actual: opensuse , win 7
Versión: 12.2 y 12.3
Escritorio: kde

Re: Imposible actualizar Manjaro

Notapor Spooky » Vie, 19 May 2017, 00:49  •  [Mensaje 5]

1persona escribió:estoy en la misma !
Uso kde
Código: Seleccionar todo
sudo pacman-mirrors -g
, pero no paso nada !
Error: no se pudo preparar la operación (no se pudieron satisfacer las dependencias)
:: gstreamer0.10-good-plugins: instalando «libsoup» (2.58.1-1) se rompe la dependencia con «libsoup-gnome»


ya encontraron la solucion?
Mi nivel de Linux en medio , medio bajo

Desde ya mucha gracias!

http://manjaro-es.org/viewtopic.php?f=6&t=2386#p12282

Enviado desde mi HUAWEI TAG-L13 mediante Tapatalk
Avatar de Usuario
Spooky

Moderador
 
Mensajes: 1422
Registrado: Sab, 06 Jul 2013, 02:04
Ubicación: Behind your computer

Re: Imposible actualizar Manjaro

Notapor Martinvk172 » Sab, 20 May 2017, 02:58  •  [Mensaje 6]

Gracias a todos por su ayuda!!
Remover gstreamer soluciono mi problema. Sigue funcionando mal la descarga, parece como si buscara varios servidores antes de poder conectar con uno. Hace algunos intentos y falla hasta que lo lograr. Buscare el tema de los mirrors en el foro. EDITADO Pude arreglar el problema de los mirrors con sudo pacman-mirrors -g.
Por cierto, luego de actualizado el sistema, apareció un problema nuevo: el reproductor sporify no inicia desde su acceso directo, y si tiro un "spotify" en la terminal me sale esto:

Código: Seleccionar todo
spotify
/usr/share/spotify/spotify: /usr/lib/libssl.so.1.0.0: version `OPENSSL_1.0.0' not found (required by /usr/share/spotify/spotify)
/usr/share/spotify/spotify: /usr/lib/libcrypto.so.1.0.0: version `OPENSSL_1.0.0' not found (required by /usr/share/spotify/spotify)
/usr/share/spotify/spotify: /usr/lib/libcurl.so.3: no version information available (required by /usr/share/spotify/spotify)


Tendrá algo que ver con la eliminación de gstreamer?
Gracias, saludos!
Avatar de Usuario
Martinvk172

Novato
 
Mensajes: 3
Registrado: Mar, 16 May 2017, 01:18
Distro actual: Manjaro
Versión: .
Escritorio: Kde
Rama: Stable

Re: Imposible actualizar Manjaro

Notapor ChristianR » Mar, 30 May 2017, 18:49  •  [Mensaje 7]

Buen día compañeros, les dejo la solución que a mi me funcionó, que es remover los archivos de gstramer0.10 y luego cambiar los mirrors.
sudo pacman -R gstreamer0.10-good-plugins

Espero les funcioné mi aporte y sigan disfrutando de manjaro :D
ChristianR

Novato
 
Mensajes: 1
Registrado: Mar, 30 May 2017, 18:42
Distro actual: Manjaro
Versión: 17.0.1
Escritorio: KDE
Rama: Stable

Re: Imposible actualizar Manjaro

Notapor IANESTUARDO » Sab, 17 Jun 2017, 01:49  •  [Mensaje 8]

sudo pacman -Rsnc gstreamer0.10 gstreamer0.10-plugins
prueben con eso en terminal a mi me funciono despues del comando actualicen el sistema utilizo manajaro con entorno Xfce
IANESTUARDO

Novato
 
Mensajes: 1
Registrado: Sab, 17 Jun 2017, 01:44
Distro actual: manjaro
Versión: fringilla
Escritorio: xfce
Rama: archlinux


  • Temas Parecidos
    Respuestas
    Vistas
    Último mensaje

Volver a Instalación y actualizaciones



¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 1 invitado




StaffBorrar las cookies


cron
^ Ir Arriba