Error del S.O. al instalar Drivers Propietarios Ati

¿Problemas con tu hardware? Aquí encontrarás respuestas.
Reglas del Foro
Lea las normas y conductas de la comunidad en "Zona Normatividad".
Busca antes de preguntar en Google y en el buscador de este foro.
Si se soluciona tu problema presione el botón en V de color verde, Imagen, para añadir un [Solucionado].

Error del S.O. al instalar Drivers Propietarios Ati

Notapor CGI » Jue, 28 Dic 2017, 02:20  •  [Mensaje 1]

Hola buen día comunidad de Manjaro

Uso Manjaro 17.0.6 x86_64 Plasma KDE, tengo experiencia usando Linux anteriormente y siempre por alguna razon termino en windows :/ . Hay algo que no he podido lograr en varias distribuciones y es lograr funcionar OpenGL4 con mi tarjeta de video Ati Radeon HD 6770, el cuál soporta opengl4.1 http://www.amd.com/en-us/products/graph ... 6000/6770# , con las últimas versiones de Mesa siempre obtengo OpenGL 3.3 y el driver propietario AMD no sirve al ejecutarlo en otras distribuciones. Ustedes se preguntarán ¿si ya tiengo OpenGL3.3 para que quiero el OpenGL4? el punto es que uso software 3D como Blender, Maya, 3dsMax y también uso Unreal Engine 4 y es éste programa el que me pide OpenGL4. Hace dos semanas que decidí migrar completamente a Linux porque me aburrí de esa mugre de windows anhelando un poco de seguridad y privacidad y viendo que se puede hacer funcionar Unreal Engine 4 de forma nativa en Linux pero llevo más de dos semanas intentando conseguir OpenGL4 y en ninguna distribuición actual funciona:
-Inicié con KaliLinux, logré compilar Unreal pero presentaba errores gráficos imperdonables.
-Pasé a Mageia 6 y los drivers Mesa 17 solo me ofrecen opengl 3.0 no se porqué. Usando Vmware14 la aceleración 3D por hardware no funciona al tener drivers opengl viejos https://drive.google.com/file/d/1vhmnwO ... sp=sharing
-Pasé a Ubuntu 17.10 donde siguía con OpenGL3.0
-Luego de investigar mucho, entendí que los drivers propietarios AMD funcionan en versiones antiguas de ubuntu (AMD no ofrece soporte actualmente :/ ) https://openbenchmarking.org/result/131 ... 600GALLI21 aquí usaron ubuntu 13.04 y obtuvieron opengl 4.1 usando drivers propietarios AMD https://www.phoronix.com/scan.php?page= ... 6770&num=3
-Probé con ubuntu 14.02 e instalé los drivers Catalyst consiguiendo por fin OpenGL4.5 https://drive.google.com/file/d/1DPEYA5 ... sp=sharing lo malo es que es una versión antigua de ubuntu y tengo problemas con las dependencias al instalar programas además no me gusta ubuntu.
-Mirando distribuciones en DistroWatch, me llamó mucho la atención Manjaro y en el apartado de Paquetes ví la versión de ati-driver que soportaba https://drive.google.com/file/d/1qdd-7_ ... sp=sharing 15.2 , la misma que tenía instalado en ubuntu 14.02 donde logré opengl4.5, además ví en el video de presentación de Manjaro que ofrecía la opción de elegir entre drivers propietarios o opensource, algo que me alegró mucho con Manjaro porque ninguna distribución ofrecía eso, "por fin, una distribución que ofrece Drivers-AMD asi sean los antiguos, ahora si podré obtener OpenGL4.0 :D, dije yo" y ahora que veo una luz al final del tunel con Manjaro, se me ha presentado el siguiente problema:
1. Inicialmente los drivers OpenSource en Manjaro 17.0.6 me ofrecen opengl3.0 https://drive.google.com/file/d/1y4BVq0 ... sp=sharing
2. En Preferencias del Sistema/Configuración de hardware, le dí click derecho en 'Ati-Catalyst' e instalar, luego reinicié el PC y al cargar el S.O. me muestra el siguiente código y no arranca Manjaro, tuve que reinstalarlo:
Código: Seleccionar todo
Starting version 235
/dev/sdc7: clean, 252192/4743168 files, 2063164/18944240 blocks
[5.347516] sd 14:0:0:0: [sdd] No caching mode page found
[5.347605] sd 14:0:0:0: [sdd] Assuming drive cache: Write through
[5.948706] cgroup: cgroup2: unknown option "nsdelegate"
[12.173059] uclogic 0003:256C:006E.0005: No inputs registered, leaving

3. Luego de volver a instalar Manjaro, intenté dándo click aquí https://drive.google.com/file/d/1eMuPW9 ... sp=sharing luego dí click derecho en el driver opensource 'desinstalar' luego reinicié el PC y al iniciar el S.O. me mostró lo siguiente https://drive.google.com/file/d/12YYAjc ... sp=sharing y el código llegó hasta aquí https://drive.google.com/file/d/1pGF38L ... sp=sharing y no avanza más así lo reinicie varias veces llega hasta ahí y Manjaro no inicia.
4. He instalado Manjaro por tercera vez y ahora no sé que hacer para instalar ese driver propietario Ati que me permite "eso creo yo" obtener OpenGL4 así como funcionó en Ubuntu 14.02 https://drive.google.com/file/d/1DPEYA5 ... sp=sharing
Me agrada demaciado Manjaro y creí que funcionaría el Ati-driver-catalyst pero nada :cry:
Alguien ayudeme por favor, llevo más de dos semanas resolviendo un sinfin de problemas con varias distribuciones Linux para lograr obtener opengl4 y ahora que Manjaro es tan genial no funciona ._. y no quiero tener que volver a esa porquería de windows por ésto :(
Sin más, gracias a ustedes por leerme, esto tan dispendioso pero necesito demostrar que lo he intentado todo.
CGI

Novato
 
Mensajes: 1
Registrado: Mar, 26 Dic 2017, 20:08
Distro actual: Manjaro
Versión: 17.06
Escritorio: KDE Plasma
Rama: Stable

Re: Error del S.O. al instalar Drivers Propietarios Ati

Notapor lexetam » Vie, 29 Dic 2017, 00:26  •  [Mensaje 2]

Hola, en el wiki de manajro hay un apartado para la instalación de catalyst

https://wiki.manjaro.org/index.php/Catalyst
Avatar de Usuario
lexetam

Aprendiz
 
Mensajes: 22
Registrado: Lun, 07 Ago 2017, 15:52
Distro actual: Manjaro
Versión: 17.0.4
Escritorio: KDE
Rama: stable


  • Temas Parecidos
    Respuestas
    Vistas
    Último mensaje

Volver a Hardware



¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 0 invitados




StaffBorrar las cookies


^ Ir Arriba